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Sequencher Connections 
 

 
Sequencher Connections is a whole new way of performing multiple analyses on multiple sequences 
in parallel. This saves you time and gives you the opportunity to look at your data using different settings or 
parameters. Connections, at the time of writing, allows you to use BLAST, Primer-BLAST, and 
Local-BLAST (if you have installed them) on individual sequences and MUSCLE on a group of related 
sequences. For these reasons we differentiate between individual and group or grouped data when talking 
about Connections. Not only can you view your BLAST, Primer-BLAST, Local-BLAST, or MUSCLE 
results at the time you performed the analysis, but you can also review your results later on since they are 
saved with your project.  This tutorial covers working with sessions with BLAST, Primer-BLAST, and 
MUSCLE. For information on working with Local-BLAST in Connections, please refer to the 
Sequencher Connections chapter of the Sequencher User Manual or to the Local-BLAST 
tutorial. 

ABOUT DATA SOURCES, SESSIONS, AND CHANNELS 
A data source in the context of Connections is a Sequencher project containing reads and contigs. A 
session is a coordinated set of data and analyses that operate on that data. A channel is an analysis such as 
MUSCLE or service such as BLAST. We will be using these terms throughout the tutorial. 

GETTING STARTED 
In this tutorial, you will learn how to use Connections, how to create a session, how to name your 
session and change its channel options. You will also learn how to review a session that you created 
previously. 
 

•   Launch Sequencher.  
•   Go to the File menu and select Import > Sequencher Project… 
•   Navigate to the Sample Data folder inside the Sequencher application folder. 
•   Choose the Sequencher Connections project and select the Open button. 
•   Select File > Save Project and enter a name of Sequencher Connections and a 

location of your Desktop or Documents folder and select the Save button. 
•   Click on the Label column header in the Project Window to sort the project items by Label. 

This will make it easier to locate sequences later in the tutorial. 
 

This project contains a set of fish mitochondrial sub-sequences. During the course of the tutorial, you will find 
out exactly what these sequences represent. These sequences will be analysed using BLAST. In the second 
part of the tutorial, you will analyse the sequences with Primer-BLAST and in part three, you will analyse 
the sequences with MUSCLE.   There are also smaller sections on Restored Results and Deleting Sessions. 
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LAUNCHING A CONNECTIONS SESSION WITH BLAST 
In this session, you will use the default settings for BLAST. The sequences have been labeled using 
Sequencher’s Label command to make it easier for you to choose the correct sequences in this tutorial. 
 

•   Select only the sequences labeled in blue (Tilapia). You should have selected 4 sequences.  
•   Go to the Window menu and select Add to Connections Session… 
•   Click on the radio button Add to new Connections Session for individual 

sequences. 
•   Type Tilapia in the New Session Name input field. 
 

 
•   Click on the OK button. 
•   A new Connections session starts. You will see a window with a table pane at the top and a 

pane at the bottom containing a series of tabs. 
•   Right-click on the BLAST-nr column header and choose Run on Each Sequence. 
•   Watch the table as the colors of each cell in the BLAST-nr channel column change from white to 

orange to cyan to yellow and then to green and the status finally changes to Done. Once all the 
cells contain a green Done, your analyses are complete and you may review the results. 

 

 
 
•   If you get any red Failed statuses in the cells, try to rerun the blasts for those particular cells by 

right-clicking in the cells and selecting Run. If the status is still Failed, then check the Options. 
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VIEWING THE RESULTS 
Once the BLAST run has finished, clicking in a Done cell will change the view in the Web View tab to 
the familiar BLAST results page. You can scroll up and down, and click on links.  
 

•   Click on the Done cell in the BLAST-nr column for the sequence called FISH067-08|Oreochromis in 
the Connections Session table. 

•   In the Web View tab, scroll down until you see the Graphic Summary representing the 
alignment of your query sequence and the alignments found by the BLAST algorithm. 
 

 
 
•   Click on the first red line. The web page jumps down to the alignment. 
 

 
 
•   Click on the Sequence ID link. A new window opens displaying the Feature Table for the 

hit sequence to which your target has aligned. Notice that this is mitochondrial                                                                                                                                                                                                                      
Cytochrome oxidase subunit 1. 

•   Now click on a different green Done cell and see if you get the same or similar results for the 
other sequences.  

CHANGING OPTIONS FOR A BLAST SESSION 
BLAST offers a number of options for refining the scope of your search. Some of these options change 
values. One of the most important options is the E or expectation value. Another option you can change is the 
database to be searched. If you do not know much about the region you have just sequenced, you may want 
to cast the widest possible net by choosing the blastn algorithm rather than the megablast algorithm, which is 
the default setting. You can also ask BLAST to send you more than the default 10 results and descriptions as 
shown in this part of the tutorial below. 
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•   Right-click in the header of the BLAST-nr channel.  
•   Choose Insert BLAST Channel Before. 
•   Right-click again in the header of the newly created BLAST-nr channel. 
•   Choose Options… from the context-sensitive menu. 
 

 
 
•   The Channel Options dialog opens. This dialog will contain a tab for each channel in your 

session. 
•   Click on Optimize for and change the algorithm to Somewhat similar (blastn), 

clicking OK on the subsequent warning dialog. 
•   Change the word size to 11 to match the dialog you see below. 
•   Click on the Default Graphic Color picker, choose a new color for this channel (this will be 

visible in the Schematic), and click on the OK button. 
•   Change the number of alignments to 50 by choosing this value from the Alignments drop-

down menu. 
•   Change the number of descriptions to 50 by choosing this value from the Descriptions drop-

down menu. 
 

 
 
•   Click the OK button to save these changes. This closes the Channel Options dialog. 
•   Right-click on this channel’s column header and choose Run on Each Sequence. 
•   If you get any red Failed statuses in the cells, try to rerun the blasts for those particular cells by 

right-clicking in the cells and selecting Run. 
 

You will see more results and descriptions with the above settings than in the first part of the tutorial. Note 
that, although you see more results, these are still all mitochondrial fish sequences related to the initial 
sequences you chose as your queries. It will not always be the case that the results are so highly related, this 
will depend on your query sequence as well as which database you chose to search and the settings you used.  
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LAUNCHING A CONNECTIONS SESSION WITH PRIMER-BLAST 
Primer-BLAST combines the capabilities of two resources into one. The first resource is the ability to 
harness the Primer 3 algorithm to predict primers and the second resource is the ability to use BLAST to 
check the specificity of those predictions. We will look at primer prediction only in this tutorial. 
 

•   Select the sequences labeled with magenta (Brittle star) in Sequencher’s Project 
Window. You should have selected 4 sequences.  

•   Go to the Window menu and select Add to Connections Session… 
•   Click on the radio button Add to new Connections Session for individual 

sequences. Notice that your previous session is listed in the Session Launcher dialog. 
•   Type Brittle star into the New Session Name input field. 
 

 
 
•   Click on the OK button. 
•   A new Connections session starts. You will see a window with a table pane at the top and a 

pane at the bottom containing a series of tabs. 
•   Right-click on the Primer-BLAST column header and choose Run on Each Sequence. 
•   Watch the table as the colors of each cell change from white to cyan to green and the status changes 

to Done. Once all the cells contain a green Done, your analyses are complete and you may 
review the results. 

•   If you get any red Failed statuses in the cells, try to rerun the blasts for those particular cells by 
right-clicking in the cells and selecting Run. 

•   Click on the Done cell for the sequence called ACAP127-12|Ophiactis in the Primer-BLAST column. 
The Primer-BLAST results page loads in the Web View tab. 

 
You can see your results displayed in this view with 10 sets of primer pairs in the display.  
 

•   Scroll down the page to view the detailed primer reports. You can see part of such a report in the 
image below. 
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CHANGING OPTIONS FOR YOUR PRIMER-BLAST SESSION 
Primer-BLAST offers a number of options for refining the scope of your search for primers. Some of these 
options are specific to the primer calculations but you may also check on the specificity of your primers. Note 
that if you do check your primers specificity, the search will take longer. 
 

•   Right-click in the header of the Primer-BLAST channel.  
•   Choose Insert Primer-BLAST Channel Before. 
•   Right-click in the header of the new Primer-BLAST channel and choose Options… from the 

context-sensitive menu. 
•   The Channel Options dialog opens. This dialog opens at the Primer-BLAST channel 

options tab for the new channel but will also contain a tab for each channel in your session. 
•   Click on the Default Graphic Color picker and choose a new color for this channel (this will 

be visible in the Schematic) and select the OK button. 
•   Change the PCR product size minimum from 70 to 500. 
•   Change the value of the Number of primers to return to 20. 
•   Change the Max% for GC Content to 75. 
 

 
 
•   Click on the OK button. 
•   Right-click on the new Primer-BLAST column header and choose Run on Each Sequence. 
•   Watch the table as the colors of each cell change from white to cyan to yellow to green and the 

status changes to Done. You should get a single red Failed status for one cell where Primer-
BLAST failed to find any results within the minimum PCR product size which was the same as the 
length for this sequence. 
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•   Click on one of the Done cells and click on the Web View tab. 
•   You can see your results displayed in a Graphical View with 10 sets of primer pairs in the display.  

 

 
 
•   Click on the Text tab. Now right-click in the tab view and choose Save as Text…, this saves 

a copy of the Primer-BLAST information to your chosen location.  
 

Notice that if you insert the two sets of Primer-BLAST channels as neighbours, you can easily jump from 
one set of results to the other. In the next section, you will see how to view all the results for a single 
sequence using the Schematic. 

LOOKING AT THE RESULTS USING THE SCHEMATIC 
The Schematic enables you to combine several sets of different analyses into a single graphic. Thus for 
each sequence you are exploring, you can not only look at the results from several different BLAST searches 
but also combine that with the results of your Primer-BLAST analysis. This means that you can double 
check, with the aid of BLAST, that you are amplifying precisely the region you want and be assured of that 
in one single view instead of hopping about between different views or even different programs. 
 

•   Right-click on the sequence name in the second column of the session table and choose Show 
Schematic. 

 

 
 

•   A new dialog opens with the results of the all the analyses you have run on your data in one view.  
•   Place your cursor over one of the colored lines in the Schematic, note the contents of the tooltip 

that appears. It contains information on the hit sequence in a BLAST search. 
•   Scroll in the window until you see Primer-BLAST results. The arrows represent the primers and 

the thin lines connecting the arrows represent the insert. Place your cursor over one of the colored 
lines and note the contents of the tooltip. It contains information on the primer pair. 
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•   Click on any line in the Schematic and see how it highlights a region corresponding to the range 
of the line you clicked on. 

•   Click on the radio button next to Bases and scroll to the bottom of the Schematic. You will see 
the bases contained within the range of the line you clicked on and their positions. 

 

 
•   In the bottom pane of the Schematic window, scroll down to view the table of results.  
•   Close the Schematic window. 

SAVING PRIMERS TO YOUR PROJECT 
Once you have reviewed the results using the Schematic and have decided which primers best suit your 
purposes, you will want to save the primers to your project. A new tab called the Primer Picker tab 
appears when you click in any cell containing a Done or Done status in a Primer-BLAST channel. 
 

•   Click in the Done cell for the sequence called ACAP-12| Ophiactis. 
•   Click on the Primer Picker tab and review the primers listed there. 
•   Click in the checkbox next each primer pair you want to save to your project. 
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•   Click on the Save Selected button. The primers will appear in your project. Note that the 
primers contain the name of the parent sequence plus a number (for the primer pair) and either F 
or R for the direction of the primer. 

•   Double-click on the primers called ACAP127-12_Ophiactis_1F and ACAP127-
12_Ophiactis_1R to open them in the Sequence Editor. Notice that the bases of 
ACAP127-12_Ophiactis_1F are colored green and ACAP127-12_Ophiactis_1R are colored red. This 
convention will help you to recognize the directionality of your primers simply by looking at the 
bases. 

 

 

LAUNCHING A CONNECTIONS SESSION WITH MUSCLE 
In this session, you will use the default settings for MUSCLE. The sequences have been labeled using 
Sequencher’s Label command to make it easier for you to choose the correct sequences in this tutorial. 
 

•   Select the sequences labeled in cyan (Snapping shrimp). You should have selected 11 sequences.  
•   Go to the Window menu and select Add to Connections Session… 
•   Click on the radio button Add to new Connections Session for grouped 

sequences. 
•   Type Snapping shrimp into the New Session Name input field. 
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•   Click on the OK button. 
 

A new window opens containing the grouped sequences session. You will notice that there is only one line in 
the table and that it is called Group 1. The name is already highlighted so that you can type in a new, more 
memorable name. The table gives you information on how many sequences are contained in the group. 
 

 
 

•   Type the name Synalpheus to replace the words Group 1. 
 

 
 
•   Right-click on the MUSCLE-1 column header and choose Run on Each Group. 
•   The colors and text in the MUSCLE-1 column change in response to the status of the analysis. 
•   When the color in the cell is green and the text has changed to Done, click in the cell. 
•   The contents of the first tab change from the Connections landing page to a display of the aligned 

sequences. 
 

 
 
•   Click on the Tree tab.  
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•   You now see a phylogram of the members of your data set. 
•   Right-click in the page and change the tree from rectangular to circular. 
•   Leave the session window open. 

ADDING A SECOND CONNECTIONS SESSION WITH MUSCLE 
When you add sequences to Connections, you can either add them to a new session or an existing 
session. If you are working with a set of related sequences you might want to add those to an existing group 
session so you can compare and contrast your results. The sequences are added as a new group and appear 
in the Connections table as an additional row. 
 

•   Select all the sequences in the project - green (Sharks), magenta (Brittle stars), cyan (Snapping 
shrimp), and blue (Tilapia). You should have selected 24 sequences.  

•   Go to the Window menu and select Add to Connections Session… 
•   Click on the radio button Add to an existing Connections Session. 
•   Choose the Snapping shrimp group. 

 

 
 
•   Click on the OK button. 
•   Notice that a new group has been added to the open session. Leave this name as Group 2. 
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•   Right-click on the MUSCLE-2 column header and choose Run on Each Group. 
•   When the color in both cells is green and the text has changed to Done, click in the Group 2 

cell in the MUSCLE-2 channel. In the Web View, you will see the alignment for all the 
sequences.  

 

 
 

In this example, you can see that the Synalpheus portion of the alignment is much more fragmented, there 
are more gaps as a result of adding in the additional sequences, and fewer matching bases.  
 

•   Now switch to the Alignment tab. Here you scroll right and left to view the alignment rather 
than down and up with the results in the Web View tab. 

 

 
 
•   Now switch to the Tree tab. 
 



 
Gene Codes Corporation ©2017            Sequencher Connections                                                   p. 15 of 18 
 

 
 
•   Now click in the Done cell in the MUSCLE-2 Synalpheus group. In the Tree tab, you will see 

the tree for these sequences. In this way, you can visually compare the results of several sets of 
alignments quickly. 

 
In this example, you added both sets of data to the same session, this makes sense for closely related data. If 
your data is less closely related, you can add it to a new Connections session for grouped sequences 
instead.  

THE SESSION IS SAVED WITH YOUR PROJECT  
Your session is saved with your project and can be reviewed next time you open your project. You can test this 
with the following steps: 
 

•   Close the project. 
•   You should be prompted to save.  Go ahead and Save. 
•   Exit/Quit Sequencher. 

 
The next time you open the Sequencher Connections project, you will be able to review the results 
from this tutorial as follows. 
 

•   Launch Sequencher.  
•   Go to the File menu and select File > Open Project… 
•   Navigate to the location you saved your project to earlier. 
•   Choose the Sequencher Connections project and select the Open button. 
•   Go to the Window menu and choose Open Existing Connections Session… 
•   Save the project if prompted to do so. 
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•   Choose the Snapping shrimp Grouped session by clicking on it. Notice that it shows 2 groups 
are associated with this session. 

•   Click on the OK button.  
 
The session opens and the saved results from the last time you used this project are now available for review.  

THE SESSION EXPIRES FROM NCBI BUT NOT FROM SEQUENCHER 
If more than 36 hours have passed since you ran a BLAST or Primer-BLAST analysis, the results will 
have expired from the NCBI website. When you click on a Done status cell, Sequencher will display a 
different view in the Web View tab informing you that the results have expired. However, since 
Connections has saved your results, you will still be able to view them. 
 

•   Click on the Text tab to view the text version of your search results. 
•   Right-click on the sequence name in the second column of the session table and choose Show 

Schematic to view the graphic view of your results. 
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Note that if you rerun any of the existing results and the runs complete, you will lose the originals. If some 
time has passed since you last ran a search and you suspect new data may have been added to the databases 
you searched against, add a new channel and just search using that channel, then use the Schematic view 
to compare the results. 

RESTORED RESULTS 
If your sessions have earlier search results associated with them, those results are restored when those 
sessions are reopened.  Any previous green Done statuses will have gray Done statuses.   
 
Likewise, if your sessions have earlier search results associated with them and you choose to run another 
query, then cancel that request before the query is complete, your earlier saved results are also restored.  

DELETING SESSIONS 
If you have accidentally added sessions or no longer need sessions, you can remove them from your project.  
 

•   Go to the Window menu and choose Delete Existing Connections Session… 
•   In the Delete Session(s) dialog, select the session or sessions you wish to delete and click on 

the Delete Selected Session(s) button.  You will be prompted to Cancel or Continue.   
 
If you select Continue and you have any open and/or running sessions, your running sessions will be 
stopped, closed, and removed from your project. 
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If you select Continue and you have no open and/or running sessions, your selected sessions will simply 
be removed from your project. 
 
If you select Cancel, any running or open sessions will remain so and will not be removed from your project. 

CONCLUSION 
In this tutorial, you have worked with Connections. You have learned how to add data to a session, how 
to give your session a meaningful name, and how to change session options. You have used BLAST, 
Primer-BLAST, and MUSCLE. You have learned how to view your results using the Schematic view 
and how to view your MUSCLE results as phylograms. You have also learned that your results are saved 
with your project and can be reviewed at a later time. You have also learned how to save primers from a 
Primer-BLAST session to your project.  Finally, you have learned that, although results expire from the 
NCBI website, you can always view your results in the Text and Schematic views.  


