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Introduction

In this CodeLinker RNA-Seq tutorial, you are going learn how to import differential
expression data from a Cufflinks suite run and how to perform analyses on that data. You
will use data from the paper by Coffelt et al." First you will focus on learning how to
prepare your data and remove any missing values. Then you will proceed through some
of the key analyses that you can do. Once you have completed this Tutorial you will be
able to take your own data through the same steps and even explore some of the other
analyses in the rich set of tools that CodeLinker offers.

Importing and Preparing your RNA-Seq Data

You will begin by looking at how to take differential expression output from Cuffdiff and
prepare it for analysis in CodeLinker.

You will import differential expression output from Cuffdiff into CodeLinker. The “Cuffdiff
exp_diff” import template pulls the FPKM (FPKM stands for Fragments Per Kilobase of
transcript per Million mapped reads) values from any of the “exp.diff” output files from
Cuffdiff, the final step in the Cufflinks suite workflow. The FPKM value gives a measure of
the relative abundance of transcripts. In some cases, you may have 0 values in some loci
across all your data. These 0 values may be due to technical issues with your samples
and need to be removed.

Before you start

Unzip the Mouse Cancer Genome Data folder to a suitable location, you will need to use
the items contained within.

Data Import

Launch CodeLinker

Go to File > Import > Gene Expression Data.

Set the Template to Cuffdiff exp_diff and Gene Database to GenBank.

Click Select File... and browse to the file gene_exp.diff and select it. Click Open
and then Import.

The Import Data window (see image below) will appear. Click OK.

's. B. Coffelt, K. Kersten, C. W. Doornebal, J. Weiden, K. Vrijland, C.-S. Hau, N. J. M. Verstegen, M. Ciampricotti, L. J. A.
C. Hawinkels, J. J. K. E. de Visser, IL-17-producing y6 T cells and neutrophils conspire to promote breast cancer

metastasis. Nature 522, 345348 (2015)
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Source File: gene_exp
Gene Database: |GenBank i
Options
Data Size:
I~ Transpose
9 samples by 23 414 genes
[V Use Sample Names Note: the preview is not displaying all of the
expression data that will be imported.

[¥ Use Gene Names

Preview:
Genes
0610007P14Rik 0610009B22Rik 0610009E02Rik
KEP-4 .30937 4.26153 43.0028
KEP-6 1.01271 4.39129 46.489
KEP-7 1.35299 4.03328 56.1662
KEP-8 1.9193 476592 38.5274
KEP-9 0676302 3.05065 54.3097
Wild Type-1 1.55787 4.22485 53.485
Wild Type-2 315711 3.88927 28.4524
Wild Type-3 0.851831 3.65769 39.9282
Wild Type-5 289999 298887 32.8427
A ]
OK

Normalizing data

Before you can normalize the data you have to remove genes that have a zero value for
at least one of the samples. This is a two-step process. The first step is to remove all
zero values. The second step is to remove the genes that have missing values as a result
of the first step.

Highlight “gene_exp” and go to Data > Remove Values.

In the Remove Values window, set Removal Technique to by Expression
Value. For Expression Value make sure that <= is selected and that the value is
0 and click OK.

Highlight “Removed: v <= 0.0” and go to Data > Estimate Missing Values....

In the Estimate Missing Values window, set Remove Genes That Have Missing
Values: to 1 and click OK.

Next you will normalize the data so the genes are on a similar scale.

Highlight “Estimated: #mv < 1 | median” and go to Data > Normalize.

In the Normalization (Page 1 of 2) window, select Other Transformations and
select Next.

In the Normalization (Page 2 of 2) window, select Standardize and select
Finish.
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The IBIS Classifier Search

The next thing you will need to do is filter down the number of genes to a more reasonable
number for CodeLinker’s analyses to work with. You are going to use the (IBIS) Integrated
Bayesian Inference System to create a gene list of the most important genes. This is an
advanced data-mining algorithm designed to find patterns or variable sets that have
predictive value. For our data set, the samples can be classified as either “Tumor
bearing” or “Wild Type”, IBIS will find genes that fit those criteria.

You begin by importing a variable file that classifies each of the samples into one of two
categories. The variable file is just a text file with one condition for each sample in the
same order as the data file.

Highlight “gene_exp” and go to File > Import > Variable.

You need to import a Source File, click the button labeled ... and browse to the
file called Variable file.txt and click Open followed by OK.

Click Preview to confirm that the variables are in the same order as the data file.
Select Close and then Import.

There will now be a small purple V on the icon for this dataset. The variables will be
applied to everything downstream from that dataset.

You are now ready to use the IBIS Classifier Search. You have the options of using Linear
Discriminate Analysis (LDA) or Quadratic Discriminate Analysis (QDA) on either a single
gene or on a pair of genes. It’s best to start with an LDA/single gene analysis as this will
be the fastest option and will find the clearest examples. In this tutorial you are going to
use LDA on a single gene.

Highlight Norm: Standardized and go to Predict > IBIS Classifier Search....

In the IBIS Classifier Search window, keep the defaults and select OK.

In the IBIS Search Results window, click anywhere in the Proto-classifiers pane,
click Ctrl+A to highlight all of the genes, clicking in the top checkbox which should
place a checkmark beside all genes.

Now click Create Gene List button.
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“Variable file" | LDA | 1D -0l x|

| P

Gradient Plot Create IBIS Classifier Create Gene List...

Proto-classifiers:

84 6:6760076-6760959

I <A< <P <A< <A< <A< <F< PP <A< <A< <] <]

1000 of 1000 proto-classifiers selected Select None I

In the Create a Gene List window, enter the name and description for your gene

list and select OK.

You can also highlight a single gene in the list and select Gradient Plot, which will
show you a graphical representation of how that gene will fit the variable criteria.

Finally dismiss the IBIS Search Results dialog.

The next step is to filter the Norm:Standardized dataset.

Highlight Norm:Standardized and go to Data > Filter.

C
File Edit View | Data Statistics Explore Clustering PCA  Pre
®E M Remove Values...

Experimerasl a E&Eshmate Missing Values..,

—_— T Filter Genes...
E,m gene_exp ﬁ MNormalize k

= Remove [Filter]
=-F8 et Run external script...

L& INorm: Standardized

In the Filter Genes window, set the Filtering Operation to Gene List Filtering.

Select Keep only genes that are on this list, select the Gene List you just
created, and select OK.
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Using the IBIS Classifier Search feature, you have now condensed the dataset down to
1000 genes that best fit the experimental variables. This will help the downstream
analyses be more effective.

Analysis in CodeLinker

Now you are going to briefly look at some of the analyses you can do in CodeLinker.
These analyses are designed to explore and expose any relationships between the
observations in your data sets. Typically, you would perform several of these analyses as
part of your overall data exploration strategy.

Principle Components Analysis

This is a statistical method that converts a large set of observations into a smaller set of
variables or principal components. It is typically used as one of a series of analytical steps
and is useful for exposing patterns in a set of data.

Highlight the filtered dataset.
2

File Edit View Data Statistics Explore Clustering PCA Pr
TR E - EATIEE T EF
ExperimemSI Genes ] Gene Lists I
& m gene_exp
== Removed: v <= 0.0
B Estimated: #mv < 1 | median

= ’ Norm: Standardized
- EP BIS search: "Variable file" | LDA | 1D

Filtered: keep {Standardized IBIS}

Go to PCA menu and select Principle Components Analysis....

In the PCA window, make sure that Genes is selected for PCA Orientation and
select OK.

Click on the 'El button to display the two conditions as different colors.
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EHScore Plot: PCA: genes

H-axis: IPC1 LI Y-axis: IPC 2 LI Z-axis: IPC3 LI _I QI 2‘

Color by:

EHScore Plot: PCA: genes

X-axis: IPC1 LI Y-axis: IPC 2 LI Z-axis: IPC 3 Ll _I ﬂl E

Color by:

B [\ [Variabie fie <varisble Type 1> ~

B [ [varisbie fle <variable Type 1> ~

[ wild Type-5

PC2

Self-Organizing Maps (SOMs)

The SOM is a type of Clustering algorithm that is used to produce a low dimension
representation of the input samples and automatically classify them. The SOM algorithm
tries to assign the data observations to nodes, but unlike other clustering algorithms won’t
force data into each node. You determine the size and shape of the network. Not all of the
nodes will have data clustered on them.

Highlight the filtered dataset.

Go to Clustering > Self-Organizing Map....

In the Self Organizing Map window, keep all of the defaults except for
Orientation and Map Dimensions. Set Orientation to Samples. For the Map
Dimensions, you will need to decide how many nodes you want. (For this tutorial
2 x 2 is a good starting point and these are shown in the images below. For other
data sets you should explore other combinations.) Once you've set those, select
OK.

If you click on a cluster, the pane on the right will show the samples that are in that
cluster.
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=10l ]
Samples in cluster #3
KEP-4

#SOM Results: SOM: samples | 2x2 | Euclid

KEP-B
KEP-7

251 Profile Plot: Cluster #3

-2.08
#SOM Results: SOM: samples | 2x2 | Euclid |0l x|
Samples in cluster #1
Id Type-1
ild Type-2
ld Type-3
Wild Type-5
<
. e——'e
251 Profile Plot: Cluster #1

-2.08

Hierarchical Clustering

Hierarchical clustering is a method of dividing observations into groups or clusters such
that the observations in any particular group are more closely related to each other than
they are to observations in another cluster. The method goes through several steps to
produce a dendrogram of the clusters.

Highlight the filtered dataset.
Go to Clustering > Hierarchical Clustering.
Keep all of the settings as shown below and select OK.
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Hierarchical Clusteri

[ Dataset Information
Number of Genes: 1000 Number of Samples: 9
~Clustering Orientation

& Cluster Genes " Cluster Samples

[ Distance Measurements

Between Data Points: |Euclidean %%

Between Clusters: Average Linkage ¥

Algorithm Properties

Type: |Agglomerative LI

OK |

You will need to change the Data Range. Double-click on the color scale as
shown below.

@]Dendrogram Plot: Hier: genes | Euclid | avera:

Set the Minimum to -2 and the Maximum to 2 and close the window. (You can
also change the color palette in this menu if you so desire.)

You are going to look at some of the genes in closer detail. Go to the Edit menu
and select Find. Type Prdx5 into the Find what text entry box. Select Find.
Highlight 30 genes to the right-hand of Pdrx5, right click, and select Coordinate
Plot as shown below.

@ Customize...
Resize...
Hide Color Matrix

Show Color Matrix

NG_000079.6:15898797-15910204

LOC105245296 Nup107
LOC105247217
1830127 LO7 Rik
GCeacam10

GmS5960

Apmap

Gm34143,5t¢18

Lgalsa

Adora3, Tmigd3

GnbS Myo5c

9130401MO1Rik
Rbpms

Gm11557
Bys!

Dhis1
Prok2

6 ExportImage... Ctrl+l &

[] Scatter Plot

| Coordinate Plot

m Summary’3 Coordinate Plot

Profile Matching

T2

Highlight all the genes in the Gene pane, right-click, and select Create Gene List
from Selection.
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Gpx1
Coti
Aldoa
Prr13
R3hdm4
M Mcempi

NG_000067 £

NG_000069 £

Glrx
NC_000069.6:158571726-158571779
Arpc3

M Tspo
Gm5483

Stfa2 Select All
BC100530

=G Select None B

Prok2 4 Resize...

LyBg @ Customize...

C177 6 Export Image... Ctrl+l
a Lookup Gene Ctrl+L
5 Annotate Ctrl+E
Create Gene List from SelectiokCtrHS
m Summary Statistics Ctrl+U

* Choose a name for the list and select OK. Close the Coordinate Plot.

* Highlight the filtered dataset and go to Data > Filter Genes....

* Select Gene List Filtering from the Filtering Operation drop-down list. Make
sure that the gene list you just created is selected in the Gene List drop-down list.
Click the radio button Keep only genes that are in this list, and select OK.

The dataset has 1000 genes and 9 samples.
Filtering Operation: IGene List Fittering LI

' Keep only genes that are in this list

" Remove all genes that are in this list

Gene List: [Soa Gt - |
Tips I OK Cancel I

* Repeat the steps to create a Hierarchical Clustering on the new filtered list you
just created.

* Now you can see the dendogram more clearly.

* You will need to change the Data Range. Double-click on the color scale and click
Use actual range. Close the window.

* Click on the button, this will show you which rows correspond to which
samples.

* Highlight all of the genes in the Hierarchical Plot.

* Right-click and select Coordinate Plot.

Gene Codes Cornoration ©2017 CodelLinker RNA-Sea Tutorial pn. 10 of 13



[&]Dendrogram Plot: Hier: genes | Euclid | average =10l

0 ! 2 aria e <Variable Type 1=
a7 003 119 9‘ ‘_5] ariable file <Variable Type 1

Bys!

NC_000079.6:15898797-15910204

1830127 L07 Rik
Geacam10
Gm34143,5618
Lgalsa
Adora3,Tmigd3
GnbS MyoSe
Gmases

Gm5960
Dstn, Gm33804

Gm11557

GmB314
Gm5863
Y

Gm5652

Adam15
Rab28

Apmap
PdG
Rbpms
Dhist
Prol2
S8
Prdss
LySg
Exti2

KEP-4
KEP-5
KEP-7
KEP-8
KEP-9
Wild Type-1
wild Type-2
wild Type-3
wild Type-5

=
K I

What you see in this plot is the expression profile for each of these genes, in your cell
lines. If you click on a specific gene in the Gene list, its plot line is emphasized and the
variation in expression of that gene across all the cell lines is clearly displayed. In this
case we can see the elevation of the expression curve in the cancer lines and a
concomitant depression in the Wild Type samples.

Acoordinate Plot: Selected Data =0l x|

2

Expression
o

-

Gm34143,5tx18

| | ' | | ! \( !
i ' | ) ' Y \ M Lgals9
! ! | ! ' | ! ' M Adora3, Thigd3
| ' 1 | ' | | | | GnhS MyoSc
T @ b @ @ - o @ » M Pk3

5 5 ; 5 Tmem33

Z Z Z Z Ebi3 —

Sample NC_000DG7 5:46056694-46056773
M Mosnd3 =
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Searching GenBank

Once you have a list of interesting genes, you will want to find out more about them.
CodelLinker has a preference which allows you to link to GenBank and search the
Nucleotide database using just a gene name.

Go to the Tools menu and select Preferences.
Click on the Gene Database tab.
Ensure that the Gene Display Name is set to Gene Name.

Copy and paste the following text into the GenBank text box :
https://www.ncbi.nlm.nih.gov/entrez/query.fcgi?cmd=Search&term="MMC ID"&db=Nucleotide&doptcmdI=GenBank
If you cannot copy and paste the URL, you may need to enter it manually.

Click OK.

You can now test this as follows:

In the Coordinate Plot, right-click on the gene called Lcn2. Select Lookup Gene.
Your default browser will open at the GenBank entry for Lcn2.

You can also perform a Lookup Gene search from any Gene List.

Go to the Gene Lists tab.
Click on the plus symbol (+) next to your chosen Gene List.

Experiments | Genes Gene Lists |
X
E Gene List 1

5] Gene List 2
[5) Selected list

\3‘1 Aldoa
é AloxSap

Anxal
Arpc3
BC100530
Cd52

2y Chilt Mybph
=y Cotlt
=y Glrx
Gms483
= Gpx1
=y Iitm2
fitm3
=y LySg ¢

oo Ctrl+
NC_0i

é NC:OOOJ?S 5:79347206-79347272

NRORC

Pick a gene name and right click on it. Select Lookup Gene. Your default browser will
open showing a display similar to the one shown below.
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S NCBI  Resources @ HowTo @

Nucleotide [Nucleotide | ["Len2”] Q[ seorct)

Create alert Advanced

) NCBI is phasing out seqy Gl bers in September 2016. Please use accession.versionl Read more...

Species Summary » 20 per page ~ Sort by Default order + Sendto: ~
Animals (361

Bacteria (29

Customize See LCN2 lipocalin 2 in the Gene database

len2 reference es Transcript (1) Protein (1)

q
Molecule types

genomic DNA/RNA (251)

mMRNA (205 Items: 1 to 20 of 499
Customize .
Page [1 | of25 Next>

Source databases © Found 505 nucleotide sequences. Nucleotide (499) EST (3) GSS(3)
INSDC (GenBank) (174 §
RefSeq (323 [J Homo sapiens full open reading frame cDNA clone RZPD0834D0537D for gene LCN2_lipocalin 2
Customize 1. (oncogene 24p3); complete cds, without stopcodon

594 bp linear MRNA
Genesc Accession: CR542092.1 GI: 49457136
compartments senBank ASTA Graph
Plasmid -

Conclusion

This has been a sampling of just some of the vast array of tools available in CodeLinker
Miner and how they relate to RNA-Seq data. You could repeat this tutorial using the
isoform_exp.diff data file and see if you get similar results or even experiment with some
of the settings.

Please continue exploring Codelinker’s features with both RNA-Seq data and Microarray
data. CodelLinker has an in-depth Help utility with information on all CodeLinker’s
features, and even more tutorials.

If you have any questions about features, installation, or want help using the program,
please let us know at support@genecodes.com or call 734-769-7249.
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